Openmoko Bug #2479: playing a sound and suspending at the same time => no sound at resume on 2.6.39

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Openmoko Bug #2479: playing a sound and suspending at the same time => no sound at resume on 2.6.39

Openmoko Public Trac
#2479: playing a sound and suspending at the same time => no sound at resume on
2.6.39
----------------------+-----------------------------------------------------
 Reporter:  GNUtoo    |          Owner:  openmoko-kernel
     Type:  defect    |         Status:  new            
 Priority:  high      |      Milestone:                
Component:  kernel    |        Version:                
 Severity:  critical  |       Keywords:                
 Haspatch:  0         |      Blockedby:                
Estimated:            |    Patchreview:                
 Blocking:            |   Reproducible:  always        
----------------------+-----------------------------------------------------
 doing the following result in not beeing to play a sound anymore at
 resume:
 {{{
 aplay 05.wav
 echo mem > /sys/power/state #in a new console
 #press the power button
 #still no sound
 killall aplay
 aplay 05.wav #still no sound
 }}}

--
Ticket URL: <https://docs.openmoko.org/trac/ticket/2479>
docs.openmoko.org <http://docs.openmoko.org/trac/>
openmoko trac
Reply | Threaded
Open this post in threaded view
|

Re: Openmoko Bug #2479: playing a sound and suspending at the same time => no sound at resume on 2.6.39

Openmoko Public Trac
#2479: playing a sound and suspending at the same time => no sound at resume on
2.6.39
----------------------+-----------------------------------------------------
 Reporter:  GNUtoo    |          Owner:  openmoko-kernel
     Type:  defect    |         Status:  new            
 Priority:  high      |      Milestone:                
Component:  kernel    |        Version:                
 Severity:  critical  |       Keywords:                
 Haspatch:  0         |      Blockedby:                
Estimated:            |    Patchreview:                
 Blocking:            |   Reproducible:  always        
----------------------+-----------------------------------------------------

Comment(by GNUtoo):

 The kernel used is this one:
 https://gitorious.org/shr/linux/commits/shr-2.6.39-nodrm

--
Ticket URL: <https://docs.openmoko.org/trac/ticket/2479#comment:1>
docs.openmoko.org <http://docs.openmoko.org/trac/>
openmoko trac
Reply | Threaded
Open this post in threaded view
|

Re: Openmoko Bug #2479: playing a sound and suspending at the same time => no sound at resume on 2.6.39

Openmoko Public Trac
In reply to this post by Openmoko Public Trac
#2479: playing a sound and suspending at the same time => no sound at resume on
2.6.39
----------------------+-----------------------------------------------------
 Reporter:  GNUtoo    |          Owner:  openmoko-kernel
     Type:  defect    |         Status:  new            
 Priority:  high      |      Milestone:                
Component:  kernel    |        Version:                
 Severity:  critical  |       Keywords:                
 Haspatch:  0         |      Blockedby:                
Estimated:            |    Patchreview:                
 Blocking:            |   Reproducible:  always        
----------------------+-----------------------------------------------------

Comment(by GNUtoo):

 it does it too with speaker-test

 Also, after resume:
 {{{
 amixer -qc0 cset numid=92,name='Left Mixer Left Playback Switch' off
 amixer -qc0 cset numid=92,name='Left Mixer Left Playback Switch' on
 }}}
 makes it not silent again.

--
Ticket URL: <https://docs.openmoko.org/trac/ticket/2479#comment:2>
docs.openmoko.org <http://docs.openmoko.org/trac/>
openmoko trac