Quantcast

QtMoko v26 Qtopia Documents System

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

QtMoko v26 Qtopia Documents System

Nashvin Gangaram
Hi everyone

My Current Config is:
Qi Bootloader 1.02 (from SHR-testing feed)
uSD Card (16GB) Partitions:
512 MB: ext2: QtMoko v26
512 MB: ext2: SHR-testing (2010/05/29)
512 MB: ext2: GameRunner 0.2
Rest: fat32: General Stuff...
NAND Flash: QtMoko v26 (again, backup for when SD Card removed)

When booting from either QtMoko v26 (uSD Card or NAND Flash):
In the File Manager, i can see the "General Stuff" files above in:
/media/card/Documents/
(so I believe that I have set up /etc/fstab correctly)
but, they are not being "imported" into the Qtopia Documents System, so I cannot use them...

Any ideas / suggestions?

Thanks,
Nashvin

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

Radek Polak
On Tuesday 19 October 2010 10:32:35 Nashvin Gangaram wrote:

> Hi everyone
>
> My Current Config is:
> Qi Bootloader 1.02 (from SHR-testing feed)
> uSD Card (16GB) Partitions:
> 512 MB: ext2: QtMoko v26
> 512 MB: ext2: SHR-testing (2010/05/29)
> 512 MB: ext2: GameRunner 0.2
> Rest: fat32: General Stuff...
> NAND Flash: QtMoko v26 (again, backup for when SD Card removed)
>
> When booting from either QtMoko v26 (uSD Card or NAND Flash):
> In the File Manager, i can see the "General Stuff" files above in:
> /media/card/Documents/
> (so I believe that I have set up /etc/fstab correctly)
> but, they are not being "imported" into the Qtopia Documents System, so I
> cannot use them...
>
> Any ideas / suggestions?

You can try "Rescan documents" from Documents screen (the bottom right icon in
main menu). Otherwise you can try give me output of "mount" and "ls
/media/card/Documents".

Regards

Radek

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

Nashvin Gangaram
Hi Radek

Thanks, I forgot to mention I had tried to "Rescan documents" unsuccessfully.
Here is some stuff from the terminal (manually typed, so forgive typos...):

root@neo:/# mount
rootfs on / type auto (rw,noatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/mmcblk0p4 on /media/card type vfat (rw)

Kind Regards,
Nashvin



On Tue, Oct 19, 2010 at 11:51 AM, Radek Polak <[hidden email]> wrote:
On Tuesday 19 October 2010 10:32:35 Nashvin Gangaram wrote:
> Hi everyone
>
> My Current Config is:
> Qi Bootloader 1.02 (from SHR-testing feed)
> uSD Card (16GB) Partitions:
> 512 MB: ext2: QtMoko v26
> 512 MB: ext2: SHR-testing (2010/05/29)
> 512 MB: ext2: GameRunner 0.2
> Rest: fat32: General Stuff...
> NAND Flash: QtMoko v26 (again, backup for when SD Card removed)
>
> When booting from either QtMoko v26 (uSD Card or NAND Flash):
> In the File Manager, i can see the "General Stuff" files above in:
> /media/card/Documents/
> (so I believe that I have set up /etc/fstab correctly)
> but, they are not being "imported" into the Qtopia Documents System, so I
> cannot use them...
>
> Any ideas / suggestions?

You can try "Rescan documents" from Documents screen (the bottom right icon in
main menu). Otherwise you can try give me output of "mount" and "ls
/media/card/Documents".

Regards

Radek

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community


_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

sferic
Hi Nashin

in a similar situation I found it helpfus to umount the document-partition, scan the system and after cleaning the sqlite3-document-database re-mount the document-partition and scan again. After this I can reach my new Documents.

Hope, this help.
Sferic
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

Nashvin Gangaram
Hi Sferic

Thanks for the suggestion.  I'm not sure what you mean by cleaning the sqlite3-document database.  Is this performed in the "Rescan System", or separately?  Anyway, I tried to umount, rescan, mount, rescan with no luck...

Thanks
Nashvin



On Tue, Oct 19, 2010 at 4:06 PM, sferic <[hidden email]> wrote:

Hi Nashin

in a similar situation I found it helpfus to umount the document-partition,
scan the system and after cleaning the sqlite3-document-database re-mount
the document-partition and scan again. After this I can reach my new
Documents.

Hope, this help.
Sferic
--
View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/QtMoko-v26-Qtopia-Documents-System-tp5650006p5650969.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community


_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

sferic
Hi Nashin,

the document-informations are stored in several tables in the sqlite3-database /home/root/Applications/Qtopia/qtopia_db.sqlite. You can take a look into this database for example with sqliteman (and edit, if you are sure what you are doing).

Every time you rescan your documents the database should be updated - it should, but it didn't. This is on my qtmoko v25 and on your qtmoko v26 too. Only when I umount /media/card/ and rescan the documents, this database is clear - all document-informations are cleaned up. When I mount this partition again, the system finds all documents and update the database.

As you described it seems to me, qtmoko v26 has a fault in this.

Hope this helps - Greetings
Sferic
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

Jose Luis Perez Diez
In reply to this post by Nashvin Gangaram
A Dimarts 19 Octubre 2010 16:41:24, Nashvin Gangaram va escriure:
> Hi Sferic
>
> Thanks for the suggestion.  I'm not sure what you mean by cleaning the
> sqlite3-document database.  Is this performed in the "Rescan System", or
> separately?  Anyway, I tried to umount, rescan, mount, rescan with no
> luck...

Have you checked the entries for  /dev/mmcblk0p# of your fat partition on
/opt/Qtopia/etc/default/Trolltech/Storage.conf?

There are some docs abouth the contents of this file on
http://doc.qt.nokia.com/qtopia2.0/html/devices.html
http://doc.qt.nokia.com/qtextended4.4/integration-guide.html#document-content-
system

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: QtMoko v26 Qtopia Documents System

Nashvin Gangaram
Issue Resolved!!!

Thanks Jose...
/opt/Qtopia/etc/default/Trolltech/Storage.conf
showed:
/dev/mmcblk0p1
instead of:
/dev/mmcblk0p4

I thought that it looked for Documents in:
/media/card/Documents
but clearly, I was wrong...

Thanks,
Nashvin



On Wed, Oct 20, 2010 at 9:55 AM, Jose Luis Perez Diez <[hidden email]> wrote:
A Dimarts 19 Octubre 2010 16:41:24, Nashvin Gangaram va escriure:
> Hi Sferic
>
> Thanks for the suggestion.  I'm not sure what you mean by cleaning the
> sqlite3-document database.  Is this performed in the "Rescan System", or
> separately?  Anyway, I tried to umount, rescan, mount, rescan with no
> luck...

Have you checked the entries for  /dev/mmcblk0p# of your fat partition on
/opt/Qtopia/etc/default/Trolltech/Storage.conf?

There are some docs abouth the contents of this file on
http://doc.qt.nokia.com/qtopia2.0/html/devices.html
http://doc.qt.nokia.com/qtextended4.4/integration-guide.html#document-content-
system

_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community


_______________________________________________
Openmoko community mailing list
[hidden email]
http://lists.openmoko.org/mailman/listinfo/community
Loading...